Commands For Ospf

Table of Contents

8.5 Commands for OSPF

8.5.1 area authentication

Command: area <id> authentication [message-digest] no area <id> authentication
Function: Configure the authentication mode of the OSPF area. The no command restores the default value.
Parameters:

  • <id>: the area number which could be shown, in integer format, ranging from 0 to 4294967295. IP address format can also be used.
  • message-digest: proved by MD5 authentication or by simple plaintext authentication.

Command mode: OSPF Protocol Mode
Default: No authentication.
Usage guide: Set the authentication mode to plaintext authentication or MD5 authentication. The authentication mode can also be configured under the Interface Mode with a priority higher than those in the area. Ip OSPF authentication-key is required in order to set the password. No authentication mode is configured at the interface. Plaintext authentication and ?ip ospf message-digest key? commands are used to configure the MD5 key if there is MD5 authentication. The area authentication mode does not affect the authentication mode of the interface in this area.
Example: Set the authentication mode in area 0 to MD5.

active500EM(config-router)#area 0 authentication message-digest

 

8.5.2 area default-cost

Command: area <id> default-cost <cost>
no area <id> default-cost
Function: Configure the cost of sending the default summary route in the stub or NSSA area. The no command restores the default value.
Parameters:

  • <id>: the area number which could be shown as digits 0-4294967295 or as an IP address.
  • <cost>: ranges between 0 and 16777215.

Command mode: OSPF Protocol Mode
Default: OSPF cost is 1.
Usage guide: The command is only used for the ABR router connected to the stub area or NSSA area.
Example: Set the default-cost of area 1 to 10.

active500EM(config-router)#area 1 default-cost 10

 

8.5.3 area filter-list

Command: area <id> filter-list {access|prefix} {in|out}
no area <id> filter-list {access|prefix} {in|out}
Function: Configure the filter broadcasting summary route on the ABR. The no command restores the default value.
Parameters:

  • <id>: area number which could be shown in digits (ranging between 0 and 4294967295) or as an IP address.
  • access-list: appointed for use in access.
  • prefix: appointed for use in prefix-list.
  • <name>: name of the filter. The valid length is between 1 and 256.
  • ?in?: from other areas to this area.
  • ?out?: from this area to other areas.

Command mode: OSPF Protocol Mode
Default: No filter configured.
Usage guide: This command is used to restrain routes in specified areas from spreading between this area and other areas.
Example: Set a filter on the area to 1.

active500EM(config)#access-list 1 deny 172.22.0.0 0.0.0.255
active500EM(config)#access-list 1 permit any
active500EM(config)#router ospf 100
active500EM(config-router)#area 1 filter-list access 1 in

 

8.5.4 area nssa

Command: area <id> nssa [TRANSLATOR| no-redistribution |DEFAULT-ORIGINATE | no-summary] no area <id> nssa [TRANSLATOR| no-redistribution | DEFAULT-ORIGINATE | no-summary] Function: Set the area to Not-So-Stubby-Area (NSSA) area.
Parameters:

  • <id>: area number. The valid value can be a number ranging between 0 and 4294967295 or an IP address.
  • TRANLATOR = translator-role {candidate|never|always}: specifies the LSA translation mode for routes:
    • candidate: identifes if the router is elected as a translator. Type 7 LSA can be translated to Type-5 LSA. The default is candidate.
    • never: the router will never translate Type 7 LSA to Type 5 LSA.
    • always: the route will always translate Type 7 LSA to Type 5 LSA.
  • no-redistribution: never distribute external-LSA to NSSA.
  • DEFAULT-ORIGINATE=default-information-originate [metric <0-16777214>] [metric-type <1-2>]: generate the Type-7 LSA.
    • metric<0-16777214>: the metric value.
    • metric-type<1-2>: the external-LSA metric value type. The default value is 2.
  • no-summary: shows not injecting the area route to the NSSA.

Command mode: OSPF Protocol Mode
Default: No NSSA area defined.
Usage guide: The same area can not be identified as both NSSA and stub at the same time.
Example: Set area 3 to NSSA.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#area 0.0.0.51 nssa
active500EM(config-router)#area 3 nssa default-information-originate metric 34 metric-type 2 translator-role candidate no-redistribution

 

8.5.5 area range

Command: area <id> range <address> [advertise| not-advertise| substitute] no area <id> range <address>
Function: Aggregate the OSPF route on the area border. The no command cancels this function.
Parameters:

  • <id>: the area number which could be digits ranging between 0 and 4294967295 or have a value of an IP address.
  • <address>: the area network prefix and its length in <A.B.C.D/M> format.
  • advertise: advertise this area which is the default.
  • not-advertise: do not advertise this area.
  • substitute= substitute <A.B.C.D/M>: advertise this area as another prefix.
  • <A.B.C.D/M>: replace the network prefix to be advertised in this area.

Command mode: OSPF Protocol Mode
Default: Not set.
Usage guide: Use this command to aggregate routes inside an area. If the network IDs in this area are not configured continuously, a summary route can be advertised by configuring this command on ABR. This route consists of all single networks belonging to a specific range.
Example: Aggregate routes inside an area.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#area 1 range 192.16.0.0/24

 

8.5.6 area stub

Command: area <id> stub [no-summary] no area <id> stub [no-summary] Function: Define an area as a stub area. The no command cancels this function.
Parameters:

  • <id>: the area number which could be digits ranging between 0 and 4294967295 and could also have a value of an IP address.
  • no-summary: the border route area where link summary announcements stop sending to the stub area.

Command mode: OSPF Protocol Mode
Default: None.
Usage guide: Configure area stub on all routes in the stub area. There are two configuration commands for the routers in the stub area: stub and default-cost. All routers connected to the stub area should be configured with the area stub command. As for area border routers connected to the stub area, their initial cost is defined with the area default-cost command.
Default: None.
Usage guide: Defines an area as a stub area.
Example: Define an area as a stub area.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#area 1 stub

 

Command: area <id>virtual-link A.B.C.D {AUTHENTICATION|AUTH-KEY|INTERVAL}
no area <id>virtual-link A.B.C.D [AUTHENTICATION | AUTH-KEY | INTERVAL] Function: Configure a logical link between two backbone areas physically divided by a non-backbone area. The no command removes this virtual-link.
Parameters:

  • <id>: area number which could be digits ranging between 0 and 4294967295 or it can be shown as an IP address.
  • AUTHENTICATION = authentication [message-digest[message-digest-key <1-255> md5 <LINE>] |null|AUTH-KEY].
    • authentication: enable authentication on this virtual link.
    • message-digest: authentication with MD-5.
    • null: overwrite password or packet summary with null authentication.
  • AUTH-KEY: authentication-key <key>.
    • <key>: a password consists of less than 8 characters.
  • INTERVAL= [dead-interval | hello-interval |message-digest-key<1-255>md5<LINE> | retransmit-interval | transmit-delay] <value>.
    • <dead-interval>: a neighbor is considered offline for certain dead intervals without its group messages. The default is 40 seconds.
    • <hello-interval>: time interval before the router sends a hello group message. The default is 10 seconds.
    • <message-digest-key>: authentication key with MD-5.
    • <retransmit-interval>: time interval before a router retransmits a group message. The default is 5 seconds.
    • <transmit-delay>: time delay before a router sends a group message. The default is 1 second.
    • <value>:>: the delay or interval seconds. The valid range is between 1 and 65535.

Command mode: OSPF Protocol Mode
Default: None.
Usage guide: In OSPF, all non-backbone areas will be connected to a backbone area. If the connection to the backbone area is lost, a virtual link will repair the connection. The user can configure a virtual link between any two backbone area routers connected with the public non-backbone area. The protocol treats routers connected by virtual links as a point-to-point network.
Example: Configure a logical link between two backbone areas physically divided by a non-backbone area.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#area 1 virtual-link 10.10.11.50 hello 5 dead 20

Related Commands: area authentication, show ip ospf, show ip ospf virtual-links
 

8.5.8 auto-cost reference-bandwidth

Command: auto-cost reference-bandwidth <bandwith>
no auto-cost reference-bandwidth
Function: This command sets the way in which OSPF calculates the default metric value. The no command only configures the cost to the interface by types.
Parameters:

  • <bandwith>: bandwidth in Mbps. The valid range is between 1 and 4294967.

Command mode: OSPF Protocol Mode
Default: 100Mbps.
Usage guide: The interface metric value is determined by dividing the interface bandwith with the reference bandwidth. This command is mainly used for differentiating high bandwidth links. If several high bandwidth links exist, their cost can be changed by configuring a larger reference bandwidth value.
Example: This command sets the way in which OSPF calculates the default metric value.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#auto-cost reference-bandwidth 50

Related Command: ip ospf cost
 

8.5.9 compatible rfc1583

Command: compatible rfc1583
no compatible rfc1583
Function: This command configures rfc1583 compatible. The no command closes the compatibility.
Parameters: None.
Command mode: OSPF Protocol Mode
Default: rfc1583 compatible by default.
Usage guide: Configure to rfc1583 compatible.
Example: Configure to rfc1583 compatible.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#compatible rfc1583

 

8.5.10 clear ip ospf process

Command: clear ip ospf [<process-id>] process
Function: Use this command to clear and restart OSPF routing processes. A specific OSPF process will be cleared by specifying the process ID. If no process ID is entered, all OSPF processes will be cleared.
Parameters:

  • <process-id>: Process ID number. The valid range is between 1 and 65535

Command mode: Admin Mode
Default: None.
Usage guide: Clear and restart OSPF routing processes.
Example: Clear and restart OSPF routing processes.

active500EM#clear ip ospf process

 

8.5.11 debug ospf events

Command: debug ospf events [abr|asbr|lsa|nssa|os|router|vlink] no debug ospf events [abr|asbr|lsa|nssa|os|router|vlink] Function: Open debugging switches to show various OSPF event messages. The no command closes the debug switch.
Parameters:

  • abr: OSPF ABR events
  • asbr: OSPF ASBR events
  • lsa: OSPF LSA events
  • nssa: OSPF NSSA events
  • os: OSPF OS interaction events
  • router: Other router events
  • vlink: OSPF Virtual-Link events

Command mode: Admin and Global Mode
Default: Closed.
Usage guide: Open debugging switches to show various OSPF event messages.
Example: Open debugging switches to show various OSPF event messages.

active500EM#debug ospf events router

 

8.5.12 debug ospf ifsm

Command: debug ospf ifsm [status|events|timers] no debug ospf ifsm [status|events|timers] Function: Open debug switches to show the OSPF interface state. The no command closes these debug switches.
Parameters:

  • events: IFSM Event Information
  • status: IFSM Status Information
  • timers: IFSM Timer Information

Command mode: Admin Mode and Global Mode
Default: Closed.
Usage guide: Open debug switches to show the OSPF interface state.
Example: Open debug switches to show the OSPF interface state.

active500EM#debug ospf ifsm events

 

8.5.13 debug ospf lsa

Command: debug ospf lsa [generate|flooding|install|maxage|refresh] no debug ospf lsa [generate|flooding|install|maxage|refresh] Function: Open debug switches to show link state announcements. The no command closes the debug switches.
Parameters:

  • flooding: LSA Flooding
  • generate: LSA Generation
  • install: LSA Installation
  • maxage: LSA MaxAge processing
  • refresh: LSA Refreshment

Command mode: Admin Mode and Global Mode
Default: Closed.
Usage guide: Open debug switches to show link state announcements.
Example: Open debug switches to show link state announcements.

active500EM#debug ospf lsa generate

 

8.5.14 debug ospf nfsm

Command: debug ospf nfsm [status|events|timers] no debug ospf nfsm [status|events|timers] Function: Open debug switches showing OSPF neighbor states. The no command closes this debug switch.
Parameters:

  • events: NFSM Event Information
  • status: NFSM Status Information
  • timers: NFSM Timer Information

Command mode: Admin Mode and Global Mode
Default: Closed.
Usage guide: Open debug switches showing OSPF neighbor states.
Example: Open debug switches showing OSPF neighbor states.

active500EM#debug ospf nfsm events

 

8.5.15 debug ospf nsm

Command: debug ospf nsm [interface] [redistribute] no debug ospf nsm [interface] [redistribute] Function: Open the debug switch showing OSPF NSM. The no command closes this debug switch.
Parameters:

  • interface: NSM interface
  • redistribute: NSM redistribute

Command mode: Admin Mode and Global Mode
Default: Closed.
Usage guide: Open the debug switch showing OSPF NSM.
Example: Open the debug switch showing OSPF NSM.

active500EM#debug ospf nsm interface

 

8.5.16 debug ospf packet

Command: debug ospf packet [dd|detail|hello|ls-ack|ls-request|ls-update|recv|send] no debug ospf packet [dd|detail|hello|ls-ack|ls-request|ls-update|recv|send] Function: Open debug switches showing OSPF packet messages. The no command closes this debug switch.
Parameters:

  • dd: OSPF Database Description
  • detail: Detail information
  • hello: OSPF Hello
  • ls-ack: OSPF Link State Acknowledgment
  • ls-request: OSPF Link State Request
  • ls-update: OSPF Link State Update
  • recv: Packet received
  • send: Packet sent

Command mode: Admin Mode and Global Mode
Default: Closed.
Usage guide: Open debug switches showing OSPF packet messages.
Example: Open debug switches showing OSPF packet messages.

active500EM#debug ospf packet hello

 

8.5.17 debug ospf route

Command: debug ospf route [ase|ia|install|spf] no debug ospf route [ase|ia|install|spf] Function: Open debug switches showing OSPF related routes. The no command closes this debug switch.
Parameters:

  • ase: External route calculation information
  • ia: Inter-Area route calculation information
  • install: Route installation information
  • spf: SPF calculation information

Command mode: Admin Mode and Global Mode
Default: Closed.
Usage guide: Open debug switches showing OSPF related routes.
Example: Open debug switches showing OSPF related routes.

active500EM#debug ospf route spf

 

8.5.18 debug ospf redistribute message send

Command: debug ospf redistribute message send
no debug ospf redistribute message send
Function: Enable sending debug from OSPF processes redistributed to other OSPF routings. The no command disables sending command debug from OSPF processes redistributed to other OSPF routings.
Parameters: None.
Command mode: Admin Mode
Default: Disabled.
Usage guide: Enable sending debug from OSPF processes redistributed to other OSPF routings.
Example: Enable sending debug from OSPF processes redistributed to other OSPF routings.

active500EM#debug ospf redistribute message send

 

8.5.19 debug ospf redistribute route receive

Command: debug ospf redistribute route receive
no debug ospf redistribute route receive
Function: Enable/disable received routing message debug from NSM for OSPF processes.
Parameters: None.
Command mode: Admin Mode
Default: Disabled.
Usage guide: Enables/disables received routing message debug from NSM for OSPF processes.
Example: Enable/disable received routing message debug from NSM for OSPF processes.

active500EM#debug ospf redistribute route receive

 

8.5.20 default-information originate

Command: default-information originate[always|METRIC|METRICTYPE|ROUTEMAP] no default-information originate
Function: This command creates a default external route to the OSPF route area. The no command closes this feature.
Parameters:

  • always: Whether the default route exists in the software or not the default route is always advertised.
  • METRIC = metric <value>: Set the metric value for creating the default route.
    • <value>: the valid range is between 0 and 16777214. The default metric value is 0.
  • METRICTYPE = metric-type {1|2}: sets the OSPF external link type of the default route.
    • 1: set the OSPF to external type 1.
    • 2: set the OSPF to external type 2.
  • ROUTEMAP = route-map <WORD>: the routemap
    • <WORD>: route map name to be applied.

Command mode: OSPF Protocol Mode
Default: Default metric value is 10. Default OSPF external link type is 2.
Usage guide: When introducing a route into the OSPF route area with this command the system will behave like an ASBR.
Example: This command creates a default external route to the OSPF route area.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#default-information originate always metric 23 metric-type 2 route-map myinfo

Related Command: route-map
 

8.5.21 default-metric

Command: default-metric <value>
no default-metric
Function: Set the OSPF routing protocoldefault metric value. The no command returns to the default state.
Parameters:

  • <value>: metric value. The valid range is between 0 and 16777214.

Command mode: OSPF Protocol Mode
Default: The metric value is set to auto translating.
Usage guide: When the default metric value makes the metric value incompatible, the route introduced will still go through. If the metric value can not be translated, the default value provides an alternative option to carry the introduced route. This command sets all introduced routes to the same metric value. This command should be used in association with the redistribute comand.
Example: Set the OSPF routing protocol default metric value.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#default-metric 100

 

8.5.22 distance

Command: distance {<value>|ROUTEPARAMETER}
no distance ospf
Function: Configure OSPF managed distance based on route type. The no command restores the default value.
Parameters:

  • <value>: OSPF managed routing distance. Valid values are between 1-235
  • ROUTEPARAMETER: ospf {ROUTE1|ROUTE2|ROUTE3}.
    • ROUTE1= external <external-distance>: configure the distance learned from other routing areas.
      • <external-distance>: distance value ranging between 1-255.
    • ROUTE2= inter-area <inter-distance>: configures the distance value from one area to another area.
      • <inter-distance>: manages the distance value. Valid values range between 1 – 255.
    • ROUTE3= intra-area <intra-distance>: configure all distance values in one area.
      • <intra-distance>: manage distance value. Valid values are between 1 – 255.

Command mode: OSPF Protocol Mode
Default: Distance value is 110.
Usage guide: Manage distance shows the reliability of the routing message source. The distance value may range between 1 – 255. The larger the managed distance value the lower the reliability.
Example: Configure the OSPF managed distance.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#distance ospf inter-area 20 intra-area 10 external 40

 

8.5.23 distribute-list

Command: distribute-list <access-list-name> out {kernel |connected| static| rip| isis| bgp}
no distribute-list out {kernel |connected| static| rip| isis| bgp}
Function: Filter the network during routing update. The no command disables this function.
Parameters:

  • <access-list-name>: the access-list name to be applied.
  • out: filter the sent route update.
  • kernel: kernel route.
  • connected: direct route.
  • static: static route.
  • rip: RIP route.
  • isis: ISIS route
  • bgp: BGP route.

Command mode: OSPF Protocol Mode
Default: None.
Usage guide: This command is used when distributing routes from other routing protocols into the OSPF routing table.
Example: Below is the display based on the access-list list 1 of the BGP route.

active500EM#config terminal
active500EM(config)#access-list l1 permit 172.10.0.0 0.0.255.255
active500EM(config)#router ospf 100
active500EM(config-router)#redistribute bgp
active500EM(config-router)#distribute-list 1 out bgp

 

8.5.24 filter-policy

Command: filter-policy <access-list-name>
no filter-policy
Function: Use the access list to filter the route obtained by OSPF. The no command cancels the route filtering.
Parameters:

  • <access-list-name>: access list name will be applied. It can use the numeric standard IP access list and naming standard IP access list for configuration.

Command mode: OSPF Protocol Mode
Default: None.
Usage guide: This command is used to filter the route obtained by OSPF. Users should not filter any routes when the specified access list does not exist. The routes which do not match the access list permit rule will be filtered. One access list can be set for this command. Only the last configuration takes effect when configuration occurs multiple times.
Example: Use access list 1 to filter the routes which do not belong to the 172.10.0.0/16 segment.

active500EM#config terminal
active500EM(config)#access-list 1 permit 172.10.0.0 0.0.255.255
active500EM(config)#router ospf
active500EM(config-router)#filter-policy 1

 

8.5.25 host area

Command: host <host-address> area <area-id>[cost <cost>] no host <host-address> area <area-id>[cost <cost>] Function: Use this command to set a stub host which belongs to a certain area. The no command cancels this configuration.
Parameters:

  • <host-address>: host IP address. The valid format is dotted decimal notation.
  • <area-id>: area ID shown. The valid format is dotted decimal notation or an integer ranging between 0 and 4294967295.
  • <cost>: entire cost. The valid value is an integer ranging between 0 and 65535. The value is defaulted to 0.

Command mode: OSPF Protocol Mode
Default: No entire set.
Usage guide: With this command you can advertise a certain specific host route as a stub link because the stub host belongs to a special router in which the setting host is not important.
Example: Use this command to set a stub host which belongs to a certain area.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#host 172.16.10.100 area 1
active500EM(config-router)#host 172.16.10.101 area 2 cost 10

 

8.5.26 ip ospf authentication

Command: ip ospf [<ip-address>] authentication [message-digest|null] no ip ospf [<ip-address>] authentication
Function: Specify the authentication mode required to send and receive OSPF packets on the interfaces. The no command cancels the authentication.
Parameters:

  • <ip-address>: the interface IP address, shown in dotted decimal notation.
  • message-digest: use MD5 authentication.
  • null: no authentication applied, which resets the password or MD5 authentication applied on the interface.

Command mode: Interface Configuration Mode
Default: Authentication not required in receiving OSPF packets on the interface.
Usage guide: Specifies the authentication mode required in sending and receiving OSPF packets on the interfaces.
Example: Specify the authentication mode required in sending and receiving OSPF packets on the interfaces.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(Config-if-Vlan1)#ip ospf authentication message-digest

 

8.5.27 ip ospf authentication-key

Command: ip ospf [<ip-address>] authentication-key <0 LINE|7 WORD|LINE>
no ip ospf [<ip-address>] authentication
Function: Specify the authentication key required to send and receive OSPF packets on the interface. The no command cancels the authentication key.
Parameters:

  • <ip-address>: interface IP address. The valid format is dotted decimal notation.
  • <LINE>: authentication key. If the key option is set to 0, plaintext key must be used. If the key option is set to 7, an encrypted string must be used. If no option is set, a plaintext key is used.

Command mode: Interface Configuration Mode
Default: Authentication is not required to receive OSPF packets on the interface.
Example: Specify the authentication key required to send and receive OSPF packets on the interface.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(Config-if-Vlan1)#ip ospf authentication-key 0 password

 

8.5.28 ip ospf cost

Command: ip ospf [<ip-address>] cost <cost>
no ip ospf [<ip-address>] cost
Function: Specify the cost required to run the OSPF protocol on the interface. The no command restores the default value.
Parameters:

  • <ip-address>: the interface IP address shown in dotted decimal notation.
  • <cost >: the cost of OSPF protocol ranging between 1-65535.

Command mode: Interface Configuration Mode
Default: OSPF cost on the interface is automatically configured based on available bandwidth.
Usage guide: Specifies the cost required to run the OSPF protocol on the interface.
Example: Specify the cost required to run the OSPF protocol on the interface.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(Config-if-Vlan1)#ip ospf cost 3

 

8.5.29 ip ospf database-filter

Command: ip ospf [<ip-address>] database-filter all out
no ip ospf [<ip-address>] database-filter
Function: This command opens the LSA database filter switch on a specific interface. The no command closes the filter switch.
Parameters:

  • <ip-address>: interface IP address. The valid format is dotted decimal notation.
  • all: all LSAs.
  • out: sent LSAs.

Command mode: Interface Configuration Mode
Default: The filter switch is closed.
Example: This command opens the LSA database filter switch on a specific interface.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(Config-if-Vlan1)#ip ospf database-filter all out

 

8.5.30 ip ospf dead-interval

Command: ip ospf [<ips-address>] dead-interval <time >
no ip ospf [<ip-address>] dead-interval
Function: Specify the dead interval for a neighboring Layer 3 switch. The no command restores the default value.
Parameters:

  • <ip-address>: the interface IP address, values are shown in dotted decimal notation.
  • <time >: the dead interval length of the neighboring Layer 3 switches shown in seconds and ranging between 1 an 65535.

Command mode: Interface Configuration Mode
Default: The default dead interval time is 40 seconds (normally 4 times the hello-interval).
Usage guide: If no Hello data packet is received after the dead-interval period, the active5000EM is considered inaccessible and invalid. This command modifies the dead interval value of the neighboring active500EMs according to the actual link state. The set dead-interval value is written into the Hello packet and transmitted. To ensure the normal operation of the OSPF protocol the dead-interval between adjacent Layer 3 switches should be at least 4 times the hello-interval value.
Example: Specify the dead interval for a neighboring active500EM.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(Config-if-Vlan1)#ip ospf dead-interval 80

 

8.5.31 ip ospf disable all

Command: ip ospf disable all
no ip ospf disable all
Function: Stop the OSPF group process on the interface.
Parameters: None.
Command mode: Interface Configuration Mode
Default: None.
Usage guide: This command resets the network area command and stops group processing on a specific interface.
Example: Reset the network area command and stop group processing on a specific interface.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(Config-if-Vlan1)#ip ospf disable all

 

8.5.32 ip ospf hello-interval

Command: ip ospf [<ip-address>] hello-interval <time>
no ip ospf [<ip-address>] hello-interval
Function: Specify the hello-interval. The no command restores the default value.
Parameters:

  • <ip-address>: the interface IP address shown in dotted decimal notation.
  • <time>: the sending Hello packet interval. The interval is shown in seconds and ranges between 1 and 65535.

Command mode: Interface Configuration Mode
Default: The hello-interval on the interface is 10 seconds.
Usage guide: Hello data packets are the most common packets. They are periodically sent to adjacent active500EM switches in order to discover and maintain adjacent relationships, elect DR, and/or BDR. The user sets the hello-interval value into the Hello packet and transmits. The lower the hello-interval value, the sooner the network topological structure is discovered and the larger the cost. To ensure normal operation of OSPF protocols, the hello-interval parameter between the active500EM switches, adjacent to the interface, must be configured correctly.
Example: Specify the hello-interval.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(Config-if-Vlan1)#ip ospf hello-interval 20

Related command: ip ospf dead-interval
 

8.5.33 ip ospf message-digest-key

Command: ip ospf [<ip-address>] message-digest-key <key-id> MD5 <0 LINE|7 WORD|LINE>
no ip ospf [<ip-address>] message-digest-key <key-id>
Function: Specify the key ID and value of MD5 authentication on the interface. The no command restores the default value.
Parameters:

  • <ip-address>: interface IP address. The valid format is dotted decimal notation.
  • <key-id>: key ID. The valid range is between 1 and 255.
  • <LINE>: OSPF key. If the key option is set to 0, plaintext key is used. If the key option is set to 7, an encrypted string is used. If no option is set, a plaintext key is used.

Command mode: Interface Configuration Mode
Default: MD5 key is not configured.
Usage guide: MD5 key encrypted authentication is used to ensure the safety between the OSPF routers on the network. The same key ID and key should be configured between neighbors when using this command. Otherwsie, no adjacent relationship will be created.
Example: Specify the key ID and value of MD5 authentication on the interface.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(Config-if-Vlan1)#ip ospf message-digest-key 2 MD5 0 yourpassword

 

8.5.34 ip ospf mtu

Command: ip ospf mtu <mtu>
no ip ospf mtu
Function: Specify the MTU value of the interface to the OSPF group structure according to the parameter set. The no command restores the default value.
Parameters:

  • <mtu>: interface MTU value. The valid range is between 576 and 65535.

Command mode: Interface Configuration Mode.
Default: Use the interface MTU acquired from the kernel.
Usage guide: The interface value configured by this command is only used by the OSPF protocol. However, the kernel is updated.
Example: Specify the MTU value of the interface to the OSPF group structure according to the parameter set.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(Config-if-Vlan1)#ip ospf mtu 1480

 

8.5.35 ip ospf mtu-ignore

Command: ip ospf <ip-address> mtu-ignore
no ip ospf <ip-address> mtu-ignore
Function: Use this command so that the MTU size is not checked when switching to DD. The no command ensures MTU size check when switching to DD.
Parameters:

  • <ip-address>: interface IP address. The valid format is dotted decimal notation.

Command mode: Interface Configuration Mode
Default: Checks the MTU size in the DD switch.
Usage guide: Use this command so that the MTU size is not checked when switching to DD.
Example: Use this command so that the MTU size is not checked when switching to DD.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(Config-if-Vlan1)#ip ospf mtu-ignore

 

8.5.36 ip ospf network

Command ip ospf network {broadcast | non-broadcast | point-to-point | point-to-multipoint}
no ip ospf network
Function: This command configures the OSPF network type. The no command restores the default value.
Parameters:

  • broadcast: sets the OSPF network type to broadcast.
  • non-broadcast: sets the OSPF network type to NBMA.
  • point-to-point: sets the OSPF network type to point-to-point.
  • point-to-multipoint: sets the OSPF network type to point-to-multipoint.

Command mode: Interface Configuration Mode
Default: The default OSPF network type is broadcast.
Usage guide: This command configures the OSPF network type.
Example: The configuration below sets the OSPF network type of the interface VLAN 1 to point-to-point.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(Config-if-Vlan1)#ip ospf network point-to-point

 

8.5.37 ip ospf priority

Command: ip ospf [<ip-address>] priority <priority>
no ip ospf [<ip-address>] priority
Function: Configures the priority when electing ?Defined layer 3 switch? at the interface. The no command restores the default value.
Parameters:

  • <ip-address>: the interface IP address, valid values are formatted in dotted decimal notation.
  • <priority>: the priority, valid values range between 0 – 255.

Command mode: Interface Configuration Mode
Default: The default priority when electing DR is 1.
Usage guide: When two active500EM switches connect to the same segment, both want to be the ?Defined layer 3 switch?. The priority will determine which switch will be the defined layer 3 switch. Normally, the switch with higher priority will be selected. If the priorities are the same, the switch with the larger router-id number will be selected. A Layer 3 switch with a priority equal to 0 will not be elected as the ?Defined layer 3 switch? or ?Backup Defined Layer 3 switch?.
Example: Configure the priority of DR electing. Configure the interface VLAN 1 to no election right (set the priority to 0).

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(Config-if-Vlan1)#ip ospf priority 0

 

8.5.38 ip ospf retransmit-interval

Command: ip ospf [<ip-address>] retransmit-interval <time>
no ip ospf [<ip-address>] retransmit-interval
Function: Specify the link state announcement retransmit interval between the interface and adjacent Layer 3 switches. The no command restores the default value.
Parameters:

  • <ip-address>: interface IP address. The valid format is dotted decimal notation.
  • <time>: link state announcement retransmit interval between the interface and adjacent Layer 3 switches. The valid value is in seconds and ranges between 1 and 65535.

Command mode: Interface Configuration Mode
Default: Retransmit interval is 5 seconds.
Usage guide: When a Layer 3 switch transmits LSA to its neighbor, it will maintain the link state announcements until confirmation from the object side is received. If the confirmation packet is not received within the interval, the LSA will be retransmitted. The retransmit interval must be larger than the time it takes to make a round between two Layer 3 switches.
Example: Configure the LSA retransmit interval of interface VLAN 1 to 10 seconds.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(Config-if-Vlan1)#ip ospf retransmit-interval 10

 

8.5.39 ip ospf transmit-delay

Command: ip ospf [<ip-address>] transmit-delay<time>
no ip ospf [<ip-address>] transmit-delay
Function: Set the LSA transmit delay value. The no command restores the default value.
Parameters:

  • <ip-address>: interface IP address. The valid format is dotted decimal notation.
  • <time>: transmit delay value of link state announcements between the interface and adjacent Layer 3 switches. The valid value is seconds and the valid ranges is between 1 and 65535.

Command mode: Interface Configuration Mode
Default: 1 second.
Usage guide: The LSA ages over time in the Layer 3 switches but not in the network transmit process. By adding the transit-delay prior to sending the LSA, the LSA will be sent before it ages.
Example: Set the LSA transmit delay of interface vlan1 to 3 seconds.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(Config-if-Vlan1)#ip ospf transmit-delay 3

 

8.5.40 key

Command: key <keyid>
no key <keyid>
Function: This command manages and adds keys in the key chain. The no command deletes one key.
Parameters:

  • <keyid>: key ID. The valid range is between 0 and 2147483647.

Command Mode: Keychain Mode and Keychain-key Mode
Default: None.
Usage guide: This command enters the Keychain-key Mode and sets the passwords corresponding to the keys.
Example: Manage and add keys in the keychain.

active500EM#config terminal
active500EM(config)#key chain mychain
active500EM(config-keychain)#key 1
active500EM(config-keychain-key)#

Related Commands: key chain, key-string, accept-lifetime, send-lifetime
 

8.5.41 key chain

Command: key chain <name-of-chain>
no key chain < name-of-chain >
Function: This command enters keychain manage mode and configures a keychain. The no command deletes one keychain.
Parameters:

  • <name-of-chain>: name string of the keychain. The length is not specifically limited.

Command mode: Global Mode and Keychain Mode
Default: None.
Usage guide: This command enters Keychain Manage Mode and configures a keychain.
Example: This command enters Keychain Manage Mode and configures a keychain.

active500EM#config terminal
active500EM(config)#key chain mychain
active500EM(config-keychain)#

 

8.5.42 log-adjacency-changes detail

Command: log-adjacency-changes detail
no log-adjacency-changes detail
Function: This command allows a log for OSPF adjacencent changes to be kept.
Parameters: None.
Command mode: OSPF Protocol Configuration Mode
Default: No OSPF adjacency change log kept.
Usage guide: When this command is configured, the OSPF adjacencent change information will be recorded into a log.
Example: Allow a log for OSPF adjacency changes to be kept.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#log-adjacency-changes detail

 

8.5.43 max-concurrent-dd

Command: max-concurrent-dd <value>
no max-concurrent-dd
Function: This command sets the maximum number of dd concurrent packets in the OSPF process. The no command restores the default.
Parameters:

  • <value>: value. The valid range is between 1 and 65535. This is the capacity to process concurrent dd data packets.

Command Mode: OSPF Protocol Mode
Default: Not set, no concurrent dd limit.
Usage guide: Specify the maximum number of concurrent dd packets in the OSPF process.
Example: Set the max concurrent dd to 20.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#max-concurrent-dd 20

 

8.5.44 neighbor

Command: neighbor <A.B.C.D> [<cost>| priority <value> | poll-interval <value>] no neighbor A.B.C.D [<cost>| priority <value> | poll-interval <value>] Function: This command configures the OSPF router connecting the NBMA network. The no command removes this configuration.
Parameters:

  • <A.B.C.D>: IP Address
  • <cost>: OSPF neighbor cost value ranging between 1-65535.
  • priority <value>: neighbor priority defaulted to 0 and ranging between 0 and 255.
  • poll-interval <value>,: 120s by default. This is the polling time before a neighbor relationship can be formed. Values range between 1-65535.

Command mode: OSPF Protocol Mode
Default: No default configuration.
Usage guide: Use this command on the NBMA network to manually configure a neighbor. Every known non-broadcasting neighbor router should be configured with a neighbor entry. The configured neighbor address should be the main address of the interface. The poll-interval should be much larger than the hello-interval.
Example: Configure the OSPF router connecting the NBMA network.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#neighbor 1.2.3.4 priority 1 poll-interval 90
active500EM(config-router)#neighbor 1.2.3.4 cost 15

 

8.5.45 network area

Command: network NETWORKADDRESS area <area-id>
no network NETWORKADDRESS area <area-id>
Function: This command enables the OSPF routing function once the interface matches the IP address with the network address. The no command removes the configuration and stops OSPF from corresponding on the interface.
Parameters:

  • NETWORKADDRESS = A.B.C.D/M | A.B.C.D X.Y.Z.W: shown with the network address prefix or the mask. The value is Wildcast mask if shown in the mask.
  • <area-id>: the IP address or area number. Valid values are in decimal integer format and range between 0 and 4294967295.

Command mode: OSPF Protocol Mode
Default: None.
Usage guide: Segments exist and belong to certain interface areas after starting hello and database interactions with the connected neighbor.
Example: Enable OSPF routing after matching the IP address with the network address.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#network 10.1.1.0/24 area 1

 

8.5.46 ospf abr-type

Command: ospf abr-type {cisco|ibm|shortcut|standard}
no ospf abr-type
Function: Use this command to configure an OSPF ABR type. The no command restores the default value.
Parameters:

  • cisco: realize through Cisco ABR.
  • ibm: realize through IBM ABR.
  • shortcut: specify a shortcut-ABR.
  • standard: realize with standard (RFC2328) ABR.

Command mode: OSPF Protocol Mode
Default: Cisco.
Usage guide: This command specifies the ABR type. This command is used for interactive operation when different OSPF methods are used and is especially useful in multiple host environments.
Example: Configure ABR as standard.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#ospf abr-type standard

 

8.5.47 ospf router-id

Command: ospf router-id <address>
no ospf router-id
Function: Specify a router ID for the OSPF process. The no command cancels the ID number.
Parameters:

  • <address>: IPv4 address format of the router-id.

Command mode: OSPF Protocol Mode
Default: None.
Usage guide: The new router-id takes effect immediately.
Example: Configure the router-id of OSPF 100 to 2.3.4.5.

active500EM#config terminal
active500EM(config)#router ospf 100
active500EM(config-router)#ospf router-id 2.3.4.5

 

8.5.48 overflow database

Command: overflow database <maxdbsize >[{hard|soft}] no overflow database
Function: This command configures the maximum LSA number. The no command cancels the limit.
Parameters:

  • <maxdbsize>: maximum LSA number. The valid range is between 0 and 4294967294.
  • soft: soft limit; warns when the border is exceeded.
  • hard: hard limit; directly close the OSPF instance when the border is exceeded. If soft and hard are not configured, the configuration is defaulted to ?hard?.

Command mode: OSPF Protocol Mode
Default: Not configured.
Usage guide: This command configures the maximum LSA number.
Example: This command configures the maximum LSA number.

active500EM#config terminal
active500EM(config)#router ospf
active500EM(config-router)#overflow database 10000 soft

 

8.5.49 overflow database external

Command: overflow database external [<maxdbsize ><maxtime>] no overflow database external [<maxdbsize ><maxtime>] Function: The command configures the size of the external link database and the wait time before the route exits the overflow state. The no command restores the default value.
Parameters:

  • <maxdbsize>: size of the external link database. The valid range is between0 and 4294967294 and is defaulted to 4294967294.
  • <maxtime>: seconds the router has to wait before exiting the database overflow. The valid range is between 0 and 65535.

Command mode: OSPF Protocol Mode
Default: None.
Usage guide: The command configures the size of the external link database and the wait time before the route exits the overflow state.
Example: The command configures the size of the external link database and the wait time before the route exits the overflow state.

active500EM#config terminal
active500EM(config)#router ospf
active500EM(config-router)#overflow database external 5 3

 

8.5.50 passive-interface

Command passive-interface <ifname> [<ip-address>] no passive-interface <ifname>[<ip-address>] Function: The hello group will not be sent on specific interfaces. The no command cancels this function.
Parameters:

  • <ifname>: the specific name of the interface.
  • <ip-address>: IP address of the interface in dotted decimal format.

Command mode: OSPF Protocol Mode
Default: None.
Usage guide: Once configured, the hello group will not be sent on specific interfaces.
Example: The hello group will not be sent on a specific interface.

active500EM#config terminal
active500EM(config)#router ospf
active500EM(config-router)#passive-interface vlan1

 

8.5.51 redistribute

Command: redistribute {kernel |connected| static| rip| isis| bgp} [metric<value>] [metric-type {1|2}][routemap< word>][tag<tag-value>] no redistribute {kernel |connected| static| rip| isis| bgp} [metric<value>] [metric-type {1|2}][routemap< word>][tag<tag-value>] Function: Introduce a route into OSPF that was learned from other routing protocols.
Parameters:

  • kernel: introduced from a kernel route.
  • connected: introduced from a direct route.
  • static: introduced from a static route.
  • rip: introduced from the RIP route.
  • isis: introduced from a ISIS route.
  • bgp: introduced from a BGP route.
  • metric <value>: the introduced metric value, ranging between 0-16777214.
  • metric-type {1|2}: the metric value type of the introduced external route, which can be 1 or 2. 2 is the default.
  • route-map <word>: point the route is introduced.
  • tag<tag-value>: external route identification number. Valid values range between 0-4294967295. The default is 0.

Command mode: OSPF Protocol Mode
Usage guide: Learn and introduce other routing protocols into the OSPF area to generate AS-external-LSAs.
Example: Introduce a route into OSPF that was learned from other routing protocols.

active500EM#config terminal
active500EM(config)#router ospf
active500EM(config-router)#redistribute bgp metric 12

 

8.5.52 redistribute ospf

Command: redistribute ospf [<process-id>] [metric<value>] [metric-type {1|2}][route-map<word>] no redistribute ospf [<process-id>] [metric<value>] [metric-type {1|2}][route-map<word>] Function: Process ID routing redistribution. The no form of this command deletes the redistribution of the process ID routing.
Parameters:

  • process-id: OSPF process ID. The default is 0.
  • metric <value>: the metric for redistributed routing. Valid values are between 0 and 16777214.
  • metric-type {1|2}: the metric type for redistributed routing. Valid values include 1 or 2. 2 is the default.
  • route-map <word>: the name for the routing map.

Command mode: OSPF Protocol Mode
Default: No OSPF redistribution by default.
Usage guide: When process-id is not input, OSPF routing will be redistributed by default (Process-id is 0).
Example: Redistribute OSPF.

active500EM(config-router)#redistribute ospf

 

8.5.53 router ospf

Command router ospf <process-id> <vrf-name>
no router ospf <process-id> <vrf-name>
Function: This command relates the OSPF process and one VPN. After configuration, all configuration commands of this OSPF are related to the VPN. The no command deletes the OSPF instance with VPN routing/forward instance.
Parameters:

  • <process-id>: specifies the ID of the OSPF process to be created. Valid values are between 1 and 65535.
  • <vrf-name>: specifies the name of the VPN routing/forward instance.

Command mode: Global Mode
Default: None.
Usage guide: Before using this command, use the ?ip vrf? command to create one VPN routing/forwarding instance. VPN routing/forward instance is related to the OSPF instance with this command.
Example: Relate OSPF with a VPN.

active500EM#config terminal
active500EM(config)#router ospf 100 VRF1
active500EM(config-router)#network 10.1.1.0/24 area 0

 

8.5.54 show ip ospf

Command: show ip ospf [<process-id>] Function: Display OSPF main messages.
Parameters:

  • <process-id>: the process ID, ranging between 0 and 65535.

Command mode: Admin and Configuration Mode
Default: None.
Usage guide: Display OSPF messages.
Example: Display OSPF messages.

active500EM#show ip ospf
Routing Process "ospf 0" with ID 192.168.1.1
 Process bound to VRF default
 Process uptime is 2 days 0 hour 30 minutes
 Conforms to RFC2328, and RFC1583Compatibility flag is disabled
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Refresh timer 10 secs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of non-default external LSA 0
 External LSA database is unlimited.
 Number of LSA originated 0
 Number of LSA received 0
 Number of areas attached to this router: 1
 Area 0 (BACKBONE) (Inactive)
 Number of interfaces in this area is 0(0)
 Number of fully adjacent neighbors in this area is 0
 Area has message digest authentication
SPF algorithm executed 0 times
 Number of LSA 0. Checksum Sum 0x000000
 Routing Process "ospf 10" with ID 0.0.0.0
 Process bound to VRF test
 Process uptime is 4 days 23 hours 51 minutes
 Conforms to RFC2328, and RFC1583Compatibility flag is disabled
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Refresh timer 10 secs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of non-default external LSA 0
 External LSA database is unlimited.
 Number of LSA originated 0
 Number of LSA received 0
 Number of areas attached to this router: 1
 Area 0 (BACKBONE) (Inactive)
Number of interfaces in this area is 0(0)
Number of fully adjacent neighbors in this area is 0
Area has no authentication
 SPF algorithm executed 0 times
Number of LSA 0. Checksum Sum 0x000000

 

8.5.55 show ip ospf border-routers

Command: show ip ospf [<process-id>] border-routers
Function: Display the intra-domain route entries for the switch to reach ABR and ASBR for all instances.
Parameters:

  • <process-id>: the process ID. Valid values are between 0-65535.

Command mode: Admin and Configuration Mode
Default: None.
Usage guide: Display the intra-domain route entries for the switch to reach ABR and ASBR for all instances.
Example: Display the intra-domain route entries for the switch to reach ABR and ASBR for all instances.

active500EM#show ip ospf border-routers
OSPF process 0 internal Routing Table
Codes: i - Intra-area route, I - Inter-area route
i 10.15.0.1 [10] via 10.10.0.1, Vlan1, ASBR, Area 0.0.0.0
i 172.16.10.1 [10] via 10.10.11.50, Vlan2, ABR, ASBR, Area 0.0.0.0

 

8.5.56 show ip ospf database

Command: show ip ospf [<process-id>] database[{
adv-router [{<linkstate-id>| self-originate |adv-router <advertiser-router>}] | asbr-summary[{<linkstate-id>| self-originate |adv-router <advertiser-router>}] | externel [{<linkstate-id>| self-originate |adv-router <advertiser-router>}] | network [{<linkstate-id>| self-originate |adv-router <advertiser-router>}] | nssa-external [{<linkstate-id>| self-originate |adv-router <advertiser-router>}] | opaque-area [{<linkstate-id>| self-originate |adv-router <advertiser-router>}] | opaque-as [{<linkstate-id>| self-originate |adv-router <advertiser-router>}] | opaque-link [{<linkstate-id>| self-originate |adv-router <advertiser-router>}] | router [{<linkstate-id>| self-originate |adv-router <advertiser-router>}] | summary [{<linkstate-id>| self-originate |adv-router <advertiser-router>}] |self-originate | max-age }] Function: Display the OSPF link state database messages.
Parameters:

  • <process-id>: process ID. The valid range is between 0 and 65535.
  • <linkstate-id>: link state ID, shown in point divided decimal system.
  • <advertiser-router>: ID of Advertising router, shown in point divided decimal IP address format.

Command Mode: Admin and configuration mode
Default: Not displayed.
Usage guide: According to the output messages of this command, the OSPF link state database messages can be viewed.
Example: Display the OSPF link state database messages.

active500EM#show ip ospf database
                Router Link States (Area 0.0.0.2)
Link ID         ADV Router       Age Seq#       CkSum   Link count
192.168.1.2     192.168.1.2      254 0x80000031 0xec21  1
192.168.1.3     192.168.1.3      236 0x80000033 0x0521  2
                Net Link States (Area 0.0.0.2)
Link ID         ADV Router       Age Seq#       CkSum
20.1.1.2        192.168.1.2      254 0x8000002b 0xece4
                Summary Link States (Area 0.0.0.2)
Link ID         ADV Router       Age Seq#        CkSum   Route
6.1.0.0         192.168.1.2       68 0x8000002b  0x5757  6.1.0.0/22
6.1.1.0         192.168.1.2      879 0x8000002a  0xf8bc  6.1.1.0/24
22.1.1.0        192.168.1.2      308 0x8000000c  0xc8f0  22.1.1.0/24
                ASBR-Summary Link States (Area 0.0.0.2)
Link ID         ADV Router       Age Seq#        CkSum
192.168.1.1     192.168.1.2     1702 0x8000002a  0x89c7
                AS External Link States
Link ID         ADV Router       Age Seq#        CkSum   Route
2.2.2.0         192.168.1.1     1499 0x80000056  0x3a63  E2 2.2.2.0/24 [0x0]
2.2.3.0         192.168.1.1     1103 0x8000002b  0x0ec3  E2 2.2.3.0/24 [0x0]

 

8.5.57 show ip ospf interface

Command show ip ospf interface <interface>
Function: Display the OSPF interface messages.
Parameters:

  • <interface>: the name of the interface.

Command mode: Admin and Configuration Mode
Default: None.
Usage guide: Display the OSPF interface messages.
Example: Display the OSPF interface messages.

active500EM#show ip ospf interface
Loopback is up, line protocol is up
  OSPF not enabled on this interface
Vlan1 is up, line protocol is up
Internet Address 10.10.10.50/24, Area 0.0.0.0
Process ID 0, Router ID 10.10.11.50, Network Type BROADCAST, Cost: 10
Transmit Delay is 5 sec, State Waiting, Priority 1
No designated router on this network
No backup designated router on this network
Timer intervals configured, Hello 35, Dead 35, Wait 35, Retransmit 5
Hello due in 00:00:16
Neighbor Count is 0, Adjacent neighbor count is 0

 

8.5.58 show ip ospf neighbor

Command: show ip ospf [<process-id>] neighbor [{<neighbor-id> |all |detail [all] |interface <ifaddress>}] Function: Display the OSPF adjacent point messages.
Parameters:

  • <process-id>: the process ID ranging between 0 and 65535.
  • <neighbor-id>: the dotted decimal notation neighbor ID.
  • all: display messages of all neighbors.
  • detail: display detailed messages of all neighbors.
  • <ifaddress>: interface IP address.

Command mode: Admin and Configuration Mode
Default: Not displayed.
Usage guide: OSPF neighbor state can be checked by viewing the output of this command.
Example: Display the OSPF adjacent point messages.

active500EM#show ip ospf neighbor
OSPF process 0:
Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.1       1   Full/Backup     00:00:32    6.1.1.1         Vlan1
192.168.1.3       1   Full/DR         00:00:36    20.1.1.3        Vlan2
192.168.1.3       1   Full/ -         00:00:30    20.1.1.3        VLINK2
Displayed information Explanation
Neighbor ID ID Neighbor ID
Priority Priority
State Neighbor relation state
Dead time Neighbor dead time
Address Interface Address
Interface Interface name

 

8.5.59 show ip ospf redistribute

Command: show ip ospf [<process-id>] redistribute
Function: Display the routing messages redistributed from external processes of OSPF.
Parameters:

  • <process-id>: the process ID ranging between 0 and 65535.

Command mode: Admin Mode and Configuration Mode.
Default: None.
Usage guide: Display the routing messages redistributed from external processes of OSPF.
Example: Display the routing messages redistributed from external processes of OSPF.

active500EM#show ip ospf redistribute
     ospf process 1 redistribute information?
       ospf process 2
       ospf process 3
       bgp
     ospf process 2 redistribute information?
       ospf process 1
       bgp
     ospf process 3 redistribute information?
       ospf process 1
       bgp
active500EM#show ip ospf 2 redistribute
     ospf process 2 redistribute information?
       ospf process 1
       bgp

 

8.5.60 show ip ospf route

Command: show ip ospf [<process-id>] route
Function: Display the OSPF routing table messages.
Parameters:

  • <process-id>: the process ID with valid values between 0 and 65535.

Command mode: Admin and Configuration Mode
Default: None.
Usage guide: Displays the OSPF routing table messages.
Example: Display the OSPF routing table messages.

active500EM#show ip ospf route
O  10.1.1.0/24 [10] is directly connected, Vlan1, Area 0.0.0.0
O  10.1.1.4/32 [10] via 10.1.1.4, Vlan1, Area 0.0.0.0
IA 11.1.1.0/24 [20] via 10.1.1.1, Vlan1, Area 0.0.0.0
IA 11.1.1.2/32 [20] via 10.1.1.1, Vlan1, Area 0.0.0.0
IA 12.1.1.0/24 [20] via 10.1.1.2, Vlan1, Area 0.0.0.0
IA 12.1.1.2/32 [20] via 10.1.1.2, Vlan1, Area 0.0.0.0
O  13.1.1.0/24 [10] is directly connected, Vlan4, Area 0.0.0.3
O  14.1.1.0/24 [10] is directly connected, Vlan5, Area 0.0.0.4
IA 15.1.1.0/24 [20] via 13.1.1.2, Vlan4, Area 0.0.0.3
IA 15.1.1.2/32 [20] via 13.1.1.2, Vlan4, Area 0.0.0.3
E1 100.1.0.0/16 [21] via 10.1.1.1, Vlan1
E1 100.2.0.0/16 [21] via 10.1.1.1, Vlan1

 

Command: show ip ospf [<process-id>] virtual-links
Function: Display the OSPF virtual link message.
Parameters:

  • <process-id>: process ID. The valid range is between 0 and 65535.

Command mode: Admin and Configuration Mode
Default: Not displayed.
Usage guide: Display the OSPF virtual link message.
Example: : Display the OSPF virtual link message.

active500EM#show ip ospf virtual-links
Virtual Link VLINK0 to router 10.10.0.9 is up
Transit area 0.0.0.1 via interface Vlan1
Transmit Delay is 1 sec, State Point-To-Point,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:02
Adjacency state Full
Virtual Link VLINK1 to router 10.10.0.123 is down
Transit area 0.0.0.1 via interface Vlan1
Transmit Delay is 1 sec, State Down,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in inactive
Adjacency state Down

 

8.5.62 show ip route process-detail

Command: show ip route [database] process-detail
Function: Display the IP routing table with a specific process ID or Tag.
Parameters:

  • database: displays all the routers. If no parameter is set, only effective routers will be displayed.

Command mode: Admin mode and Configure Mode
Default: Does not import any OSPF process routers.
Usage guide: Display the IP routing table with a specific process ID or Tag.
Example: Display the IP routing table with a specific process ID or Tag.

active500EM#show ip route database process-detail
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
       O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
> - selected route, * - FIB route, p - stale info
C      *> 127.0.0.0/8 is directly connected, Loopback
O       192.168.2.0/24 [110/10] is directly connected, Vlan2, 00:06:13,process 12
C      *> 192.168.2.0/24 is directly connected, Vlan2

 

8.5.63 show ip protocols

Command: show ip protocols
Function: Display the running routing protocol messages.
Parameters: None.
Command mode: Admin and Configuration Mode
Default: None.
Usage guide: Display the running routing protocol messages.
Example: Display the running routing protocol messages.

active500EM#show ip protocols
Use ?show ip protocols? command will show the messages of the routing protocol running on current layer 3 switch
For example, the displayed messages are:
Routing Protocol is "ospf 0"
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is
  Incoming update filter list for all interfaces is
  Redistributing:
  Routing for Networks:
    10.1.1.0/24
    12.1.1.0/24
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110)
    Address         Mask            Distance List
Routing Protocol is "bgp 0"
  Outgoing update filter list for all interfaces is
  Incoming update filter list for all interfaces is
  IGP synchronization is disabled
  Automatic route summarization is disabled
  Neighbor(s):
  Address          FiltIn FiltOut DistIn DistOut Weight RouteMap
Incoming Route Filter:

 

8.5.64 summary-address

Command: summary-address <A.B.C.D/M> [{not-advertise|tag<tag-value>}] Function: Summarize or restrain the external route within a specific address scope.
Parameters:

  • <A.B.C.D/M>: address scope. The valid format is dotted decimal notation (IPv4 address plus mask length).
  • not-advertised: restrain the external routes.
  • tag<tag-value>: identification label of the external routes. The valid range is between 0 and 4294967295. The default is 0.

Command Mode: OSPF Protocol Mode
Default: None.
Usage guide: When routes are introduced into OSPF from other routing protocols, it is advertised to every route in an external LSA. This command advertises one summary route for those introduced routes contained in a specific network address and mask which could reduce the size of the link state database.
Example: Summarize or restrain the external route with a specific address scope.

active500EM#config terminal
active500EM(config)#router ospf
active500EM(config-router)#summary-address 172.16.0.0/16 tag 3

 

8.5.65 timers spf

Command: timers spf <spf-delay><spf-holdtime>
no timers spf
Function: Adjust the value of the route calculating timer. The no command restores relevant values to default.
Parameters:

  • <spf-delay>: 5 seconds.
  • <spf-holdtime>: 10 seconds.

Command Mode: OSPF Protocol Mode
Default: None.
Usage guide: This command configures the time delay between receiving topology changes and SPF calculations. It also configures the hold item between two discontinuous SPF calculations.
Example: Adjust the value of the route calculation timer.

active500EM#config terminal
active500EM(config)#router ospf
active500EM(config-router)#timers spf 5 10

 


Return to Controller Wired CLI Table of Contents