Commands For Rip

8.3 Commands for RIP

8.3.1 accept-lifetime

Command: accept-lifetime <start-time> {<end-time>| duration <seconds>| infinite}
no accept-lifetime
Function: Use this command to specify a key accept on the key chain as a valid time period. The no command deletes this configuration.
Parameters:

  • <start-time>: specifies the start time of the time period. The form should be:{<hh:mm:ss><month><day><year>|<hh:mm:ss><day><month><year>}.
    • <hh:mm:ss>: time of accept-lifetime in hours, minutes, and seconds.
    • <day>: the day. The valid range is between 1 and 31.
    • <month>: month shown with the first three letters of the month, such as Jan.
    • <year>: starting year. The valid range is between 1993 and 2035.
  • <end-time>: time period due. The form should be:{<hh:mm:ss><month><day><year>|<hh:mm:ss><day><month><year>}
    • <hh:mm:ss>: time of accept-lifetime in hours, minutes and seconds.
    • <day>: the day. The valid range is between 1 -31.
    • <month>: month shown with the first three letters of the month, such as Jan.
    • <year>: starting year. The valid range is between 1993 – 2035
  • <seconds>: seconds. The valid range is between 1-2147483646.
  • infinite: the key will never be out of date.

Command mode: Keychain-key Mode
Default: No default configuration.
Usage guide: Use this command to specify a key accept value (as a valid time period) on the key chain.
Example: The example below shows the key 1 accept-lifetime configuration on the keychain named mychain.

active500EM#config terminal
active500EM(config)#key chain mychain
active500EM(config-keychain)#key 1
active500EM(config-keychain-key)#accept-lifetime 03:03:01 Dec 3 2004 04:04:02 Oct 6 2006

Related Commands: key, key-string, key chain, send-lifetime
 

8.3.2 address-family ipv4

Command: address-family ipv4 vrf <vrf-name>
no address-family ipv4 vrf <vrf-name>
Function: Configure this command to enable routing message switching among VRF and to enter the address-family mode. The no command deletes the RIP instances related to this VPN routing/forwarding instance.
Parameters:

  • <vrf-name>: VPN routing/forwarding instance name.

Command mode: Router Mode
Default: None.
Usage guide: This command is only used on the PE router. A VPN routing/forwarding instance must be generated with the command ?ip vrf? prior to using this command by which the VPN routing/forwarding instances can be related to RIP instances.
Example: Configure this command to enable routing message switching among VRF and to enter the address-family mode

active500EM#config terminal
active500EM(config)#router rip
active500EM(config-router)#address-family ipv4 vrf VRF1
active500EM(config-router-af)#

 

8.3.3 clear ip rip route

Command: clear ip rip route {<A.B.C.D/M> | kernel | static | connected | rip | ospf | isis | bgp | all}
Function: Clear a specific route in the RIP route table.
Parameters:

  • <A.B.C.D/M>: clears the routes which match the destination address from the RIP route table. Specify the IP address prefix and the length of the destination address.
  • kernel: deletes kernel routes from the RIP route table.
  • static: deletes static routes from the RIP route table.
  • connected: deletes direct routes from the RIP route table.
  • rip: only deletes RIP routes from the RIP route table.
  • ospf: only deletes OSPF routes from the RIP route table.
  • isis: only deletes ISIS routes from the RIP route table.
  • bgp: only deletes BGP routes from the RIP route table.
  • all: deletes all routes from the RIP route table.

Command mode: Admin Mode
Default: None.
Usage guide: When this command is used with the parameter of ?all?, all routes will be deleted in the RIP route. All routes will be immediately recovered, except for the rip route.
Example: Clear a specific route in the RIP route table.

active500EM#clear ip rip route 10.0.0.0/8
active500EM#clear ip rip route ospf

 

8.3.4 debug rip

Command: debug rip [events| nsm| packet[recv|send][detail]| all] no debug rip [events|nsm| packet[recv|send][detail]| all] Function: Open various RIP adjustment switches and show various adjustment debug messages. The no command closes the corresponding debug switch.
Parameters:

  • events: debug messages of RIP events.
  • nsm: communication messages between RIP and NSM.
  • packet: debug messages of RIP data packets.
  • recv: received data packetmessages.
  • send: sent data packetmessages.
  • detail: received or sent data packet messages.

Command mode: Admin and Global mode
Default: Debug switch closed.
Usage guide: Open various RIP adjustment switches and show various adjustment debug messages.
Example: Open various RIP adjustment switches and show various adjustment debug messages.

active500EM#debug rip packet
1970/01/01 01:01:43 IMI: SEND[Vlan1]: Send to 224.0.0.9:520
1970/01/01 01:01:43 IMI: SEND[Vlan1]: Send to 224.0.0.9:520
1970/01/01 01:01:47 IMI: RECV[Vlan1]: Receive from 20.1.1.2:520

 

8.3.5 debug rip redistribute message send

Command:debug rip redistribute message send
no debug rip redistribute message send
Function: Enable the debug sending messages for routing redistribution messages from the RIP OSPF process or BGP protocol. The no command disables the debug messages.
Parameters: None.
Command mode: Admin Mode
Default: Close the debug.
Usage guide: Enable sending message debug for routing redistribution messages from the RIP OSPF process or BGP protocol.
Example:Enable the debug of sending messages for routing redistribution messages from the RIP OSPF process or BGP protocol.

active500EM#debug rip redistribute message send

 

8.3.6 debug rip redistribute route receive

Command:debug rip redistribute route receive
no debug rip redistribute route receive
Function: Enable received message debug from NSM for RIP. The no command disables debugging of received messages from NSM for RIP.
Parameters: None.
Command mode: Admin Mode
Default: Close the debug.
Usage guide: Enable received message debug from NSM for RIP.
Example:Enable received message debug from NSM for RIP.

active500EM#debug rip redistribute route receive

 

8.3.7 default-information originate

Command: default-information originate
no default-information originate
Function: Allow the network 0.0.0.0 to be redistributed into the RIP. The no command disables this function.
Parameters: None.
Command Mode: Router and Address-family Mode
Default: Disabled.
Usage guide: Allow the network 0.0.0.0 to be redistributed into the RIP.
Example: Allow the network 0.0.0.0 to be redistributed into the RIP.

active500EM#config terminal
active500EM(config)#router rip
active500EM(config-router)#default-information originate

 

8.3.8 default-metric

Command: default-metric <value>
no default-metric
Function: Set the default metric value of the introduced route. The no command restores the default value to 1.
Parameters:

  • <value>: the metric value to be set with a range between 1-16.

Command mode: Router and Address-family Mode
Default: The default value is 1.
Usage guide: The default-metric command is used for setting the default route metric value of the routes from other routing protocols when distributed into the RIP routes. When using the redistribute commands for introducing routes from other protocols, the default route metric value specified by default-metric will be adopted if no specific route metric value is set.
Example: Set the default route metric value to 3 for introducing routes from other routing protocols into the RIP routes.

active500EM(config-router)#default-metric 3

Related command: redistribute

8.3.9 distance

Command: distance <number> [<A.B.C.D/M>] [<access-list-name> | <access-list-number >] no distance [<A.B.C.D/M> ] Function: Set the managed distance with this command. The no command restores the default value to 120.
Parameters:

  • <number>: specifies the distance value, ranging from 1 to 255.
  • <A.B.C.D/M>: specifies the network prefix and its length.
  • <access-list-name> | <access-list-number>: specifies the access-list name or number applied.

Command mode: Router and Address-family mode
Default: The default managing distance of RIP is 120.
Usage guide: In case there are routes from two different routing protocols to the same destination, the managing distance is then used for selecting the routes. The lower the route protocol managing distance, the more reliable the route acquired from the protocol.
Example: Set the managed distance.

active500EM#config terminal
active500EM(config)#router rip
active500EM(config-router)#distance 8 10.0.0.0/8 mylist

 

8.3.10 distribute-list

Command: distribute-list {<access-list-number | access-list-name> |prefix<prefix-list-name>} {in|out} [<ifname>] no distribute-list {<access-list-number| access-list-name> |prefix<prefix-list-name>} {in|out} [<ifname>] Function: This command uses access-list or prefix-list to filter the route update packets that are sent and received. The no command cancels this route filter function.
Parameters:

  • <access-list-number |access-list-name>: the access-list number or name to be applied.
  • <prefix-list-name>: the name of the prefix-list to be applied.
  • <ifname>: specifies the name of the interface to be applied with route filtering.

Command mode: Router and Address-family mode
Default: Disabled.
Usage guide: The filter will be applied to all the interfaces in case no specific interface is set.
Example: Filter the route packets sent and received.

active500EM#config terminal
active500EM(config)#router rip
active500EM(config-router)#distribute-list prefix myfilter in vlan 1

 

8.3.11 exit-address-family

Command: exit-address-family
Function: Exit Address-family Mode.
Parameters: None.
Command Mode: Address-family Mode
Default: None.
Usage guide: Exit Address-family Mode.
Example: Exit Address-family Mode.

active500EM(config)#router rip
active500EM(config-router)#address-family ipv4 vrf IPI
active500EM(config-router-af)#exit-address-family
active500EM(config-router)#

 

8.3.12 ip rip aggregate-address

Command: ip rip aggregate-address <A.B.C.D/M>
no ip rip aggregate-address <A.B.C.D/M>
Function: Configures RIP aggregation route. The no command deletes this configuration.
Parameters:

  • <A.B.C.D/M>: IPv4 address and mask length.

Command mode: Router or Interface Configuration Mode
Default: Disabled.
Usage guide: To configure aggregation route under Router Mode, RIP protocol must be enabled. If configured under interface Configuration Mode, the RIP protocol may not be enabled. The aggregation router can operate after the RIP protocol is enabled on the interface.
Example: Configure the aggregation route to 192.168.20.0/22 globally.

active500EM(config)#router rip
active500EM(config-router)#ip rip aggregate-address 192.168.20.0/22

 

8.3.13 ip rip authentication key-chain

Command: ip rip authentication key <name-of-chain>
no ip rip authentication key-chain
Function: Use this command to enable RIPV2 authentication on an interface and further configure the adopted key chain. The no command cancels the authentication.
Parameters:

  • <name-of-chain>: name of the adopted key chain. There may be spaces in the string. The parameter ends with enter and the string should not be longer than 256 bytes.

Command mode: Interface Configuration Mode
Default: Not configured.
Usage guide: If the authentication is configured without configuring the key chain or password used by the interface the authentication does no effect. If mode has not been configured prior to configuring this command, the mode will be set to plaintext authentication. The no command will cancel the authentication. This only cancels the authentication process when sending or receiving data packet.
Example: Use this command to enable RIPV2 authentication on an interface and further configure the adopted key chain.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(config-if-vlan1)#ip rip authentication key mykey

Related Commands: key, key chain
 

8.3.14 ip rip authentication mode

Command: ip rip authentication mode {text|md5}
no ip rip authentication mode {text|md5}
Function: Configure Authentication Mode. The no command restores the default Authentication Mode (namely Text Authentication Mode).
Parameters:

  • text: text authentication.
  • md5: MD5 authentication.

Command Mode: Interface Configuration Mode
Default: Authentication not configured.
Usage guide: RIP-I does not support authentication. RIP-II supports two authentication modes: text authentication (simple authentication) and data packet authentication (MD5 authentication). This command should be used to associate the IP RIP authentication key or string. Independently configuring the parameters will not lead to authentication.
Example: Configure Authentication Mode.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(config-if-vlan1)#ip rip authentication mode md5

Related Commands: ip rip authentication key-chain, ip rip authentication string
 

8.3.15 ip rip authentication string

Command: ip rip authentication string <text>
no ip rip authentication string
Function: Set the password used in RIP authentication. The no command cancels the authentication.
Parameters:

  • <text>: password used in authentication. The length should be 1-16 characters. A space can be used. The password should end with enter.

Command mode: Interface Mode
Default: None.
Usage guide: The IP RIP authentication key will not be able to be configured when this command is configured. A key ID value is required in MD5 authentication (1 when this command is used). The mode will be set to plaintext authentication if no mode configuration is set. The no command will cancel the authentication and cancels the authentication process when sending or receiving data packets (other than set non authentication mode). For example, enter an IP RIP authentication string ?aaa aaa? to set the password to ?aaa aaa? (which is 7 characters in length).
Example: Set the password used in RIP authentication.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(config-if-vlan1)#ip rip authentication string guest

Related Command: ip rip authentication mode
 

8.3.16 ip rip authentication cisco-compatible

Command: ip rip authentication cisco-compatible
no ip rip authentication cisco-compatible
Function: After this command is configured, the Cisco RIP packets will be able to be received by configuring the plaintext authentication or MD5 authentication.
Parameters: None.
Command mode: Interface Mode
Default: Not configured.
Usage guide: After authentication is configured on the Cisco router, the RIP packets will exceed the length of the protocol defined standard length once the number of route items is greater than 25. By configuring this command, the over-lengthen RIP packets will be receivable, instead of denied.
Example: After this command is configured, the Cisco RIP packets will be able to be received by configuring the plaintext authentication or MD5 authentication.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(config-if-vlan1)#ip rip authentication cisco-compatible

Related Command: ip rip authentication mode
 

8.3.17 ip rip receive-packet

Command: ip rip receive-packet
no ip rip receive-packet
Function: Set the interface to receive RIP packets. The no command sets the interface to not be able to receive RIP packets.
Parameters: None.
Command mode: Interface Configuration Mode
Default: Interface receives RIP packets.
Usage guide: Sets the interface to receive RIP packets.
Example: Set the interface to receive RIP packets.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(config-if-vlan1)#ip rip receive-packet

Related command: ip rip send-packet
 

8.3.18 ip rip receive version

Command: ip rip receive version { 1 | 2 | 1 2 }
no ip rip receive version
Function: Set the RIP packet version information the interface receives. The default version is 2. The no command restores the value set by using the version command.
Parameters:

  • 1: RIP version 1
  • 2: RIP version 2.
  • 1 2: RIP versions 1, 2.

Command mode: Interface Configuration Mode
Default: Version 2.
Usage guide: Sets the RIP packet version information the interface receives.
Example: Set the RIP packet version information the interface receives.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(config-if-vlan1)#ip rip receive version 1 2

Related command: version
 

8.3.19 ip rip send-packet

Command: ip rip send-packet
no ip rip send-packet
Function: Set the Interface to receive the RIP packets. The no command sets the interface to be unable to receive the RIP packets.
Parameters: None.
Command mode: Interface Configuration Mode
Default: The interface sends RIP packets.
Usage guide: Sets the Interface to receive the RIP packets.
Example: Set the Interface to receive the RIP packets.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(config-if-vlan1)#ip rip send-packet

Related command: ip rip receive-packet
 

8.3.20 ip rip send version

Command: ip rip send version { 1 | 2 | 1-compatible | 1 2}
no ip rip send version
Function: Set the RIP packet version information the interface receives. The default version is 2. The no command restores the value set by using the version command.
Parameters:

  • 1: RIP version 1
  • 2: RIP version 2
  • 1-compatible:
  • 1 2: RIP versions 1, 2.

Command mode: Interface Configuration Mode
Default: Version 2.
Usage guide: Sets the RIP packet version information the interface receives.
Example: Set the RIP packet version information the interface receives.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(config-if-vlan1)#ip rip send version 1

Related command: version
 

8.3.21 ip rip split-horizon

Command: ip rip split-horizon [poisoned] no ip rip split-horizon
Function: Enable split horizon. The no command disables split horizon.
Parameters:

  • poisoned: means configure the split horizon with poison reverse.

Command mode: Interface Configuration Mode
Default: Split horizon with poison reverse.
Usage guide: The split horizon prevents Routing Loops. It prevents layer 3 switches from broadcasting the routes which have been learned from the same interface on which the route is to be broadcasted.
Example: Enable split horizon.

active500EM#config terminal
active500EM(config)#interface vlan 1
active500EM(config-if-vlan1)#ip rip split-horizon poisoned

 

8.3.22 key

Command: key <keyid>
no key <keyid>
Function: This command is used to manage and add keys to the key chain. The no command deletes one key.
Parameters:

  • <keyid>: key ID. The valid range is between 0-2147483647.

Command mode: Keychain and Keychain-key Mode
Default: None.
Usage guide: The command enters the Keychain-key Mode and sets the passwords corresponding to the keys.
Example: This command is used to manage and add keys to the key chain.

active500EM#config terminal
active500EM(config)#key chain mychain
active500EM(config-keychain)#key 1
active500EM(config-keychain-key)#

Related Commands: key chain, key-string, accept-lifetime, send-lifetime
 

8.3.23 key chain

Command: key chain <name-of-chain>
no key chain < name-of-chain >
Function: This command is used to enter a keychain manage mode and configure a keychain.The no command deletes one keychain.
Parameters:

  • <name-of-chain>: name string of the keychain. The length of is not specifically limited.

Command mode: Global Mode
Default: None.
Usage guide: This command is used to enter a keychain manage mode and configure a keychain.
Example: This command is used to enter a keychain manage mode and configure a keychain.

active500EM#config terminal
active500EM(config)#key chain mychain
active500EM(config-keychain)#

Related Commands: key, key-string, accept-lifetime, send-lifetime
 

8.3.24 key-string

Command: key-string <text>
no key-string <text>
Function: Configure a password corresponding to a key. The no command deletes the corresponding password.
Parameters:

  • <text>: character string without a length limit. However, when referred by RIP authentication only the first 16 characters will be used.

Command mode: Keychain-key Mode
Default: None.
Usage guide: This command configures different passwords for keys with different IDs.
Example: Configure a password corresponding to a key.

active500EM#config terminal
active500EM(config)#key chain mychain
active500EM(config-keychain)#key 1
active500EM(config-keychain-key)#key-string prime

Related Commands:key, key chain, accept-lifetime, send-lifetime
 

8.3.25 maximum-prefix

Command: maximum-prefix <maximum-prefix>[<threshold>] no maximum-prefix
Function: Configure the maximum number of RIP routes in the route table. The no command cancels the limit.
Parameters:

  • <maximum-prefix>: RIP route maximum number. The valid range is between 1-65535. A warning is given when the current route number rate exceeds the threshold.
  • <threshold>: The valid range is between 1 and 100. The default is 75.

Command mode: Router Mode
Default: None.
Usage guide: The maximum RIP route limits the number of routes learned through RIP. It does not include direct route or the RIP static route configured by the route command. The base on which the comparison is performed is the number of routes marked R in the ?show ip route database? and the number of RIP routes displayed in the ?show ip route statistics? command.
Example: Configure the maximum number of RIP routes in the route table.

active500EM#config terminal
active500EM(config)#router rip
active500EM(config-router)#maximum-prefix 150

 

8.3.26 neighbor

Command: neighbor <A.B.C.D>
no neighbor <A.B.C.D>
Function: Specify the destination address required for targeted-peer sending. The no command cancels the specified address and restores all gateways to trustable.
Parameters:

  • <A.B.C.D>: the specified destination address for sending, shown in dotted decimal format.

Command mode: Router Mode
Default: Not sending any targeted peer destination addresses.
Usage guide: When used with the passive-interface command it can be configured to only send routing messages to specific neighbors.
Example: Send routing messages to a specific neighbor.

active500EM#config terminal
active500EM(config)#router rip
active500EM(config-router)#neighbor 1.1.1.1

Related command: passive-interface
 

8.3.27 network

Command: network {<A.B.C.C/M> | <ifname>}
no network {<A.B.C.C/M> | <ifname>}
Function: Configure the RIP protocol network.
Parameters:

  • <A.B.C.C/M|>: the IP address prefix.
  • <ifname>: the name of an interface.

Command mode: Router and Address-family Mode
Default: Not running RIP protocol.
Usage guide: Use this command to configure the network for sending or receiving RIP update packets. If the network is not configured, all interfaces of the network will not be able to send or receive data packets.
Example: Configure the RIP protocol network.

active500EM#config terminal
active500EM(config)#router rip
active500EM(config-router)#network 10.0.0.0/8
active500EM(config-router)#network vlan 1

Related commands: show ip rip, clear ip rip
 

8.3.28 offset-list

Command: offset-list <access-list-number|access-list-name> {in|out}<number >[<ifname>] no offset-list <access-list-number|access-list-name> {in|out}<number >[<ifname>] Function: Add an offset value to the metric value of the routes learned by RIP. The no command disables this function.
Parameters:

  • <access-list-number |access-list-name>: access-list number or name to be applied.
  • <number >: added offset value. The valid range is between 0-16.
  • <ifname>: specific interface name.

Command mode: Router and Address-family Mode
Default: Default offset value is the metric value defined by the system.
Usage guide: Add an offset value to the metric value of the routes learned by RIP.
Example: Add an offset value to the metric value of the routes learned by RIP.

active500EM#config terminal
active500EM(config)#router rip
active500EM(config-router)#offset-list 1 in 5 vlan 1

Related Command: access-list
 

8.3.29 passive-interface

Command: passive-interface <ifname>
no passive-interface <ifname>
Function: Set the RIP Layer 3 switch block RIP broadcast on a specified interface. RIP data packets will only be sent to Layer 3 switches configured with a neighbor.
Parameters:

  • <ifname>: specific interface name.

Command mode: Router Mode
Default: Not configured.
Usage guide: Set the RIP Layer 3 switch block RIP broadcast on a specified interface. RIP data packets will only be sent to Layer 3 switches configured with a neighbor.
Example: Set the RIP Layer 3 switch block RIP broadcast on a specified interface. RIP data packets will only be sent to Layer 3 switches configured with a neighbor.

active500EM#config terminal
active500EM(config)#router rip
active500EM(config-router)#passive-interface vlan 1

Related Command: show ip rip
 

8.3.30 recv-buffer-size

Command: recv-buffer-size<size>
no recv-buffer-size
Function: This command configures the RIP UDP receiving buffer zone size. The no command restores the system default.
Parameters:

  • <size>: buffer zone size in bytes. The valid range is between 8192-2147483647.

Command mode: Router Mode
Default: 8192 bytes.
Usage guide: This command configures the RIP UDP receiving buffer zone size.
Example: This command configures the RIP UDP receiving buffer zone size.

active500EM#config terminal
active500EM(config)#router rip
active500EM(config-router)#recv-buffer-size 23456789

 

8.3.31 redistribute

Command: redistribute {kernel |connected| static| ospf [<process-id>] | isis| bgp} [metric<value>] [routemap< word>] no redistribute {kernel |connected| static| ospf [<process-id>] | isis| bgp} [metric<value>] [routemap< word>] Function: Introduce the routes learned from other routing protocols into RIP.
Parameters:

  • kernel: introduced from kernel routes.
  • connected: introduced from direct routes.
  • static: introduced from static routes.
  • ospf: introduced from OSPF routes.
  • <process-id>: OSPF process ID. If no parameter is entered, the default is used. The range is between 1 to 65535.
  • isis: introduced from ISIS routes.
  • bgp: introduced from BGP routes.
  • <value>: the metric value assigned to the introduced route, ranging between 0 to 16.
  • <word>: the probe pointing to the route map for introducing routes.

Command mode: Router and Address-family Mode
Default: None.
Usage guide: Under the Address-family Mode the parameter kernel and ISIS is unavailable.
Example: Introduce the routes learned from other routing protocols into RIP.

active500EM#config terminal
active500EM(config)#router rip
active500EM(config-router)#redistribute kernel route-map ipi

Redistribute OSPFv2 routing information to RIP.

active500EM(config)#router rip
active500EM(config-router)#redistribute ospf 2

 

8.3.32 route

Command: route <A.B.C.D/M>
no route <A.B.C.D/M>
Function: This command configures a static RIP route. The no command deletes this route.
Parameters:

  • <A.B.C.D/M>: destination IP address prefix and its length.

Command mode: Router Mode
Default: None.
Usage guide: The command adds a static RIP route and is mainly used for debugging. Routes configured by this command will not appear in the kernel route table but in the RIP route database.
Example: Configure a static RIP route.

active500EM#config terminal
active500EM(config)#router rip
active500EM(config-router)#route 1.0.0.0/8

 

8.3.33 router rip

Command: router rip
no router rip
Function: Enable the RIP routing process and enter the RIP mode. The no command closes the RIP routing protocol.
Parameters: None.
Command mode: Global Mode
Default: Not running RIP route.
Usage guide: This command starts RIP routing protocol. RIP routing protocol is required to be open before configuring other RIP protocol commands.
Example: Enable RIP protocol mode.

active500EM(config)#router rip
active500EM(config-router)#

 

8.3.34 send-lifetime

Command: send-lifetime <start-time> {<end-time>| duration<seconds>| infinite}
no send-lifetime
Function: Use this command to specify a key on the keychain for the sending key time period. The no command cancels this configuration.
Parameters:

  • <start-time>: specifies the starting time of the time period. The valid form is: {<hh:mm:ss><month><day><year>|<hh:mm:ss><day><month><year>}
    • <hh:mm:ss>: valid time of accept-lifetime in hours, minutes and seconds.
    • <day>: valid day. The valid range is between 1 and 31.
    • <month>: valid month. The valid value is the first three letters of the month, such as Jan.
    • <year>: valid year. The valid range is between 1993 and 2035.
  • <end-time>: end time. The valid form is: {<hh:mm:ss><month><day><year>|<hh:mm:ss><day><month><year>}.
    • <hh:mm:ss>: valid time of accept-lifetime in hours, minutes and seconds.
    • <day>: valid day. The valid range is between 1 and 31.
    • <month>: valid month.The valid value is the first three letters of the month, such as Jan.
    • <year>: Valid year. The valid range is between 1993 and 2035.
  • <seconds>: valid period of the key in seconds. The valid range is between 1 and 2147483646.

Command mode: Keychain-key Mode
Default: No default configuration.
Usage guide: Use this command to specify a key on the keychain for the sending key time period.
Example: The example below shows the send-lifetime configuration on the keychain named mychain for key 1.

active500EM#config terminal
active500EM(config)#key chain mychain
active500EM(config-keychain)#key 1
active500EM(config-keychain-key)#send-lifetime 03:03:01Dec 3 200404:04:02Oct 6 2006

Related Commands: key, key-string, key chain, accept-lifetime
 

8.3.35 show debugging rip

Command: show debugging rip
Function: Show RIP event debugging, RIP packet debugging, and RIP nsm debugging status.
Parameters: None.
Command mode: Any Mode
Default: None.
Usage guide: Show RIP event debugging, RIP packet debugging, and RIP nsm debugging status.
Example: Show RIP event debugging, RIP packet debugging, and RIP nsm debugging status.

active500EM#show debugging rip
RIP debugging status:
RIP event debugging is on
RIP packet detail debugging is on
RIP NSM debugging is on

 

8.3.36 show ip protocols rip

Command: show ip protocols rip
Function: Show the RIP process parameter and statistic information.
Parameters: None.
Command mode: Any Mode
Default: None.
Usage guide: Show the RIP process parameter and statistic information.
Example: Show the RIP process parameter and statistic information.

active500EM#show ip protocols rip
Routing Protocol is "rip"
Sending updates every 30 seconds with +/-50%, next due in 8 seconds
Timeout after 180 seconds, garbage collect after 120 seconds
  Outgoing update filter list for all interface is not set
  Incoming update filter list for all interface is not set
  Default redistribution metric is 1
  Redistributing: static
  Default version control: send version 2, receive version 2
    Interface        Send  Recv   Key-chain
    Ethernet1/0/3    2     2
  Routing for Networks:
    Vlan1
    Vlan2
  Routing Information Sources:
    Gateway          Distance  Last Update  Bad Packets  Bad Routes
    20.1.1.1         120       00:00:31     0            0
Distance: (default is 120)
Displayed information Explanation
Sends an update every 30 seconds with +/-50%, next due in 8 seconds Sends an update every 30 secs
Timeout after 180 seconds, garbage collect after 120 seconds The route time-out event period is 180 secs, the garbage collect time is 120 seconds
Outgoing update filter list for all interfaces is not set Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set Incoming update filter list for all interfaces is not set
Default redistribution metric is 1 Default redistribution metric is 1
Redistributing: static Redistributing the static route into the RIP route
Default version control: send version 2, receive version 2 Interface: Ethernet1/0/3, Send: 2, Recv: 2, Key-chain: The interface configuration for receiving and sending packets. The receive version is 2. Keychain 1 is not configured.
Routing for Networks: Vlan1 Vlan2 The segment running RIP is Vlan 1 and Vlan 2
Routing Information Sources: Gateway: 20.1.1.1, Distance: 120, Last Update: 00:00:31, Bad Packets: 0, Bad Routes: 0 Routing information sources. The bad packets & bad routes from the gateway 20.1.1.1 are all 0. 31 seconds have passed since the last route update. The managed distance is 120
Distance: (default is 120) The default managed distance is 120

 

8.3.37 show ip rip

Command: show ip rip
Function: Show the routes in the RIP route data base.
Parameters: None.
Command mode: Any Mode
Default: None.
Usage guide: Show the routes in the RIP route data base.
Example: Show the routes in the RIP route data base.

active500EM#show ip rip
Codes: R - RIP, K - Kernel, C - Connected, S - Static, O - OSPF, I - IS-IS,
       B - BGP
   Network          Next Hop       Metric  From          If       Time
R  12.1.1.0/24      20.1.1.1            2  20.1.1.1      Vlan1    02:51
R  20.1.1.0/24                          1                Vlan1

Amongst R stands for RIP route, namely a RIP route with the destination network address 12.1.1.0, the network prefix length as 24, next-hop address at 20.1.1.1. It is learned from the Ethernet port E1/0/3 with a metric value of 2, and still has 2 minutes 51 seconds before time out.
 

8.3.38 show ip rip database

Command: show ip rip database
Function: Show the routes in the RIP route database.
Parameters: None.
Command mode: Any Mode
Default: None.
Usage guide: Show the routes in the RIP route database.
Example: Show the routes in the RIP route database.

active500EM#show ip rip database
Codes: R - RIP, K - Kernel, C - Connected, S - Static, O - OSPF, I - IS-IS,
       B -BGP
   Network          Next Hop       Metric  From          If       Time
R  10.1.1.0/24                          1                Vlan1
R  20.1.1.0/24                          1                Vlan2

Related Command: show ip rip
 

8.3.39 show ip rip interface

Command: show ip rip interface [<ifname>] Function: Show the RIP related messages.
Parameters:

  • <ifname>: the name of the interface to show the messages.

Command mode: Any Mode
Default: None.
Usage guide: Show the RIP related messages.
Example: Show the RIP related messages.

active500EM#show ip rip interface vlan 1
Vlan1 is up, line protocol is up
Routing Protocol: RIP
Receive RIP packets
Send RIP packets
Passive interface: Disabled
Split horizon: Enabled with Poisoned Reversed
IP interface address:10.1.1.1/24

 

8.3.40 show ip rip aggregate

Command show ip rip aggregate
Function Displays the IPv4 aggregation route information.
Parameters: None.
Command mode: Admin and Configuration Mode
Default: None.
Usage guide: This command is used to display the configuration of the aggregation route: Metric, Count, Suppress, etc. If configured under Global Mode, the interface display ??-?, ?Metric? is metric. ?Count? is the number of learned aggregation routes. ?Suppress? is the number of times for aggregation.
Example: Display the IPv4 aggregation route information.

active500EM(config-if-vlan1)#show ip rip agg
 Aggregate information of rip
       Network            Aggregated Ifname     Metric Count Suppress
       192.168.0.0/16       Vlan1                 1      2     0
       192.168.4.0/22        ----                 1      2     0
       192.168.4.0/24        ----                 1      1     1
                            Vlan1                 1      1     1
Displayed information Explanation
Network Route prefix and prefix length.
Aggregated Ifname To configure the interface name of the aggregation route. If the route aggregated globally, then display ??-?.
Metric Metric of aggregation route.
Count The number of learned aggregation route.
Suppress The times of aggregated for aggregation route.

 

8.3.41 timers basic

Command: timers basic <update><invalid><garbage>
no timers basic
Function: Adjust the RIP timer update, timeout, and garbage collection time. The no command restores each parameter to their default values.
Parameters:

  • <update>: sending update packet time interval. It is shown in seconds and ranges between 5 and 2147483647.
  • <invalid>: time period after which the RIP route is advertised as dead. It is shown in seconds and ranges between 5 and 2147483647.
  • <garbage>: hold time in which a route remains in the routing table after it is advertised as dead. It is shown in seconds and ranges between 5 and 2147483647.

Command mode: Router Mode
Default: <update> defaulted to 30. <invalid> defaulted to 180. <garbage> defaulted to120.
Usage guide: The system defaults broadcasting RIP update packets every 30 seconds. The route is considered invalid after 180 seconds but still exists for another 120 seconds before it is deleted from the routing table.
Example: Set the RIP update time to 20 seconds, timeout period to 80 seconds, and the garbage collection time to 60 seconds.

active500EM(config-router)#timers basic 20 80 60

 

8.3.42 version

Command: version {1 | 2}
no version
Function: Configure the RIP data packet versions sent/received by router interfaces. The no command restores the default configuration.
Parameters:

  • 1: version 1 rip.
  • 2: version 2 rip.

Command mode: Router and Address-family Mode
Default: Sent and received data packet are version 2 by default.
Usage guide: 1 refers to the active500EM sending/receiving the RIP-I data packets. 2 refers to the active500EM sending/receiving the RIP-II data packets. The RIP-II data packet is the default version.
Example: Configure the version of all RIP data packets sent/received by router interfaces to version 2.

active500EM(config-router)#version 2

Related commands: ip rip receive version, ip rip send version
 


Return to Controller Wired CLI Table of Contents